Just to be sure...
I'm trying to install AppCake+ HD v2.2 on my iPad 1 (tethered jailbroken iOS 5.0), but Cydia can't proceed because of unsolvable dependencies conflicts: AppCake+ HD requires AppSync for OS 3.2 / 4.0+ / 4.2, that are not compatible with my iOS 5.
I already installed AppSync for 5.0+, but this is not included in the dependencies list for AppCacke+ HD.
Does this mean that AppCake+ HD v.2.2 is still not compatible with iOS5 (even if AppCake+ for iPhone is)? Or maybe it's just a matter of updating the dependencies list for the HD version?